NixOS configuration for HPC cluster
https://docs.hpc.informatik.hs-fulda.de/
You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
185 lines
4.7 KiB
185 lines
4.7 KiB
diff -r -u a/CMakeLists.txt b/CMakeLists.txt
|
|
--- a/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/CMakeLists.txt 2023-05-27 21:27:08.991487355 +0200
|
|
@@ -85,10 +85,8 @@
|
|
add_subdirectory("thirdparty/source/gtest")
|
|
endif()
|
|
|
|
-set(CMAKE_INSTALL_PREFIX "/")
|
|
-
|
|
-add_subdirectory("beeond")
|
|
-add_subdirectory("beeond_thirdparty_gpl")
|
|
+# add_subdirectory("beeond")
|
|
+# add_subdirectory("beeond_thirdparty_gpl")
|
|
# add_subdirectory("client_devel")
|
|
# add_subdirectory("client_module")
|
|
add_subdirectory("common")
|
|
diff -r -u a/common/CMakeLists.txt b/common/CMakeLists.txt
|
|
--- a/common/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/common/CMakeLists.txt 2023-05-29 10:57:53.502540650 +0200
|
|
@@ -572,6 +572,5 @@
|
|
|
|
install(
|
|
TARGETS beegfs_ib
|
|
- DESTINATION "usr/lib"
|
|
COMPONENT "libbeegfs-ib"
|
|
)
|
|
diff -r -u a/ctl/CMakeLists.txt b/ctl/CMakeLists.txt
|
|
--- a/ctl/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/ctl/CMakeLists.txt 2023-05-29 10:57:13.297068443 +0200
|
|
@@ -149,6 +149,5 @@
|
|
|
|
install(
|
|
TARGETS beegfs-ctl
|
|
- DESTINATION "usr/bin"
|
|
COMPONENT "utils"
|
|
)
|
|
diff -r -u a/event_listener/CMakeLists.txt b/event_listener/CMakeLists.txt
|
|
--- a/event_listener/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/event_listener/CMakeLists.txt 2023-05-29 10:57:16.262103203 +0200
|
|
@@ -10,13 +10,12 @@
|
|
|
|
install(
|
|
TARGETS beegfs-event-listener
|
|
- DESTINATION "usr/sbin"
|
|
COMPONENT "event-listener"
|
|
)
|
|
|
|
install(
|
|
FILES "include/beegfs/beegfs_file_event_log.hpp"
|
|
- DESTINATION "usr/include/beegfs"
|
|
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/beegfs"
|
|
COMPONENT "event-listener"
|
|
)
|
|
|
|
Only in v7-7.3.3: foo
|
|
diff -r -u a/fsck/CMakeLists.txt b/fsck/CMakeLists.txt
|
|
--- a/fsck/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/fsck/CMakeLists.txt 2023-05-29 10:57:18.938134583 +0200
|
|
@@ -148,6 +148,5 @@
|
|
|
|
install(
|
|
TARGETS fsck.beegfs
|
|
- DESTINATION "sbin"
|
|
COMPONENT "utils"
|
|
)
|
|
diff -r -u a/helperd/CMakeLists.txt b/helperd/CMakeLists.txt
|
|
--- a/helperd/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/helperd/CMakeLists.txt 2023-05-29 10:57:21.185160939 +0200
|
|
@@ -59,6 +59,5 @@
|
|
|
|
install(
|
|
TARGETS beegfs-helperd
|
|
- DESTINATION "usr/sbin"
|
|
COMPONENT "helperd"
|
|
)
|
|
diff -r -u a/meta/CMakeLists.txt b/meta/CMakeLists.txt
|
|
--- a/meta/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/meta/CMakeLists.txt 2023-05-29 11:00:36.501472258 +0200
|
|
@@ -326,13 +326,12 @@
|
|
|
|
install(
|
|
TARGETS beegfs-meta
|
|
- DESTINATION "usr/sbin"
|
|
COMPONENT "meta"
|
|
)
|
|
|
|
install(
|
|
PROGRAMS "build/dist/sbin/beegfs-setup-meta"
|
|
- DESTINATION "usr/sbin"
|
|
+ TYPE BIN
|
|
COMPONENT "meta"
|
|
)
|
|
|
|
@@ -347,10 +346,3 @@
|
|
DESTINATION "etc/beegfs"
|
|
COMPONENT "meta"
|
|
)
|
|
-
|
|
-install(
|
|
- PROGRAMS "build/beegfs-meta.sh"
|
|
- RENAME "beegfs-meta"
|
|
- DESTINATION "opt/beegfs/sbin"
|
|
- COMPONENT "meta"
|
|
-)
|
|
diff -r -u a/mgmtd/CMakeLists.txt b/mgmtd/CMakeLists.txt
|
|
--- a/mgmtd/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/mgmtd/CMakeLists.txt 2023-05-29 11:00:44.428566811 +0200
|
|
@@ -161,13 +161,12 @@
|
|
|
|
install(
|
|
TARGETS beegfs-mgmtd
|
|
- DESTINATION "usr/sbin"
|
|
COMPONENT "mgmtd"
|
|
)
|
|
|
|
install(
|
|
PROGRAMS "build/dist/sbin/beegfs-setup-mgmtd"
|
|
- DESTINATION "usr/sbin"
|
|
+ TYPE BIN
|
|
COMPONENT "mgmtd"
|
|
)
|
|
|
|
@@ -182,10 +181,3 @@
|
|
DESTINATION "etc/beegfs"
|
|
COMPONENT "mgmtd"
|
|
)
|
|
-
|
|
-install(
|
|
- PROGRAMS "build/beegfs-mgmtd.sh"
|
|
- RENAME "beegfs-mgmtd"
|
|
- DESTINATION "opt/beegfs/sbin"
|
|
- COMPONENT "mgmtd"
|
|
-)
|
|
diff -r -u a/storage/CMakeLists.txt b/storage/CMakeLists.txt
|
|
--- a/storage/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/storage/CMakeLists.txt 2023-05-29 11:00:53.385673711 +0200
|
|
@@ -188,7 +188,6 @@
|
|
|
|
install(
|
|
TARGETS beegfs-storage
|
|
- DESTINATION "usr/sbin"
|
|
COMPONENT "storage"
|
|
)
|
|
|
|
@@ -200,7 +199,7 @@
|
|
|
|
install(
|
|
PROGRAMS "build/dist/sbin/beegfs-setup-storage"
|
|
- DESTINATION "usr/sbin"
|
|
+ TYPE BIN
|
|
COMPONENT "storage"
|
|
)
|
|
|
|
@@ -209,10 +208,3 @@
|
|
DESTINATION "etc/beegfs"
|
|
COMPONENT "storage"
|
|
)
|
|
-
|
|
-install(
|
|
- PROGRAMS "build/beegfs-storage.sh"
|
|
- RENAME "beegfs-storage"
|
|
- DESTINATION "opt/beegfs/sbin"
|
|
- COMPONENT "storage"
|
|
-)
|
|
diff -r -u a/upgrade/beegfs_mirror_md/CMakeLists.txt b/upgrade/beegfs_mirror_md/CMakeLists.txt
|
|
--- a/upgrade/beegfs_mirror_md/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/upgrade/beegfs_mirror_md/CMakeLists.txt 2023-05-29 10:57:40.926392744 +0200
|
|
@@ -15,6 +15,5 @@
|
|
|
|
install(
|
|
TARGETS "beegfs-mirror-md"
|
|
- DESTINATION "usr/sbin"
|
|
COMPONENT "beegfs-mirror-md"
|
|
)
|
|
diff -r -u a/utils/CMakeLists.txt b/utils/CMakeLists.txt
|
|
--- a/utils/CMakeLists.txt 2023-03-15 12:09:15.000000000 +0100
|
|
+++ b/utils/CMakeLists.txt 2023-05-29 11:01:05.123813896 +0200
|
|
@@ -6,6 +6,6 @@
|
|
|
|
install(
|
|
PROGRAMS "scripts/beegfs-check-servers" "scripts/beegfs-df" "scripts/beegfs-net"
|
|
- DESTINATION "usr/bin"
|
|
+ TYPE BIN
|
|
COMPONENT "utils"
|
|
)
|