NixOS configuration for HPC cluster
https://docs.hpc.informatik.hs-fulda.de/
You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
54 lines
938 B
54 lines
938 B
{ stdenv
|
|
, fetchzip
|
|
, coreutils
|
|
, which
|
|
, callPackage
|
|
, libbfd
|
|
, pdtoolkit ? callPackage ../pdtoolkit { }
|
|
, ...
|
|
}:
|
|
|
|
stdenv.mkDerivation rec {
|
|
pname = "tau";
|
|
version = "2.32";
|
|
|
|
src = fetchzip {
|
|
url = "https://www.cs.uoregon.edu/research/tau/tau_releases/tau-${version}.tar.gz";
|
|
hash = "sha256-0wAvssUHtB4gxRDEq7HMpBB1etLa7zHk8TK27SRmJOE=";
|
|
};
|
|
|
|
nativeBuildInputs = [
|
|
coreutils
|
|
which
|
|
];
|
|
|
|
buildInputs = [
|
|
pdtoolkit
|
|
libbfd
|
|
];
|
|
|
|
configureFlags = [
|
|
"-pdt=${pdtoolkit}"
|
|
];
|
|
|
|
prePatch = ''
|
|
patchShebangs --build configure
|
|
|
|
for file in configure $(find . -name "Makefile") $(find . -name "Makefile.skel") utils/FixMakefile; do
|
|
substituteInPlace $file \
|
|
--replace /bin/rm rm \
|
|
--replace /bin/cp cp \
|
|
--replace /bin/ln ln
|
|
done
|
|
'';
|
|
|
|
preBuild = ''
|
|
cd $out
|
|
'';
|
|
|
|
prefixKey = "-prefix=";
|
|
|
|
dontDisableStatic = true;
|
|
|
|
enableParallelBuilding = true;
|
|
}
|