NixOS configuration for HPC cluster
https://docs.hpc.informatik.hs-fulda.de/
You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
37 lines
665 B
37 lines
665 B
{ stdenv
|
|
, fetchzip
|
|
, coreutils
|
|
, ...
|
|
}:
|
|
|
|
stdenv.mkDerivation rec {
|
|
pname = "pdtoolkit";
|
|
version = "3.25.1";
|
|
|
|
src = fetchzip {
|
|
url = "https://www.cs.uoregon.edu/research/tau/pdt_releases/pdtoolkit-${version}.tar.gz";
|
|
hash = "sha256-IfSc5hlTFqW+y81z0jucVvBiRXQ9SllDsS3K8M2c5Is=";
|
|
};
|
|
|
|
nativeBuildInputs = [
|
|
coreutils
|
|
];
|
|
|
|
prePatch = ''
|
|
patchShebangs --build configure
|
|
|
|
for file in configure Makefile; do
|
|
substituteInPlace $file \
|
|
--replace /bin/rm rm \
|
|
--replace /bin/cp cp
|
|
done
|
|
'';
|
|
|
|
prefixKey = "-prefix=";
|
|
|
|
postInstall = ''
|
|
chmod -R u=rwX,g=rX,o=rX $out
|
|
'';
|
|
|
|
enableParallelBuilding = true;
|
|
}
|