NixOS configuration for HPC cluster https://docs.hpc.informatik.hs-fulda.de/
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

30 lines
624 B

{ lib, config, ... }:
with lib;
{
options.hpc.dhcp = {
reservations = mkOption {
description = ''
DHCP reservations for this host.
'';
type = types.attrsOf (types.submodule {
options = {
hwAddress = mkOption {
description = ''
MAC address of the interface in this network.
'';
type = types.str;
apply = toLower;
};
ipAddress = mkOption {
description = ''
IP address of the host.
'';
};
};
});
default = { };
};
};
}