NixOS configuration for HPC cluster https://docs.hpc.informatik.hs-fulda.de/
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

33 lines
528 B

{ lib, ... }:
with lib;
let
mkMachine = { name, type, opts ? { } }: rec {
inherit name type opts;
path = ./machines/${type};
gather = ./gathered/${name};
};
manager = mkMachine {
name = "manager";
type = "manager";
};
nodes = imap0
(nodeIndex: nodeConfig: mkMachine {
name = "node-${fixedWidthNumber 2 nodeIndex}";
type = "node";
opts = {
inherit nodeIndex nodeConfig;
};
})
(import ./machines/nodes.nix);
in
concatLists [
[ manager ]
nodes
]