NixOS configuration for HPC cluster https://docs.hpc.informatik.hs-fulda.de/
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

19 lines
373 B

{ pkgs, config, lib, ... }:
with lib;
let
mkdocsConfig = import ./config.nix {
inherit config lib;
};
mkdocsConfigYaml = pkgs.writeText "mkdocs.yaml" (generators.toYAML { } mkdocsConfig);
in
{
system.build.docs = pkgs.runCommand "docs" { } ''
${pkgs.mkdocs}/bin/mkdocs build \
--site-dir "$out" \
--config-file "${mkdocsConfigYaml}"
'';
}