NixOS deployment for LinuxLab
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

45 lines
728 B

{
imports = [
./hardware.nix
./dhcp.nix
./nfs.nix
./cache.nix
./netinstaller.nix
./wol.nix
../../client/users.nix
];
deployment = {
targetHost = "10.33.64.20";
};
networking = {
interfaces."enp4s0f0" = {
ipv4.addresses = [
{
address = "10.33.64.20";
prefixLength = 20;
}
{
address = "10.33.64.71";
prefixLength = 20;
}
];
};
interfaces."enp4s0f1" = {
ipv4.addresses = [{
address = "10.32.44.20";
prefixLength = 24;
}];
};
defaultGateway = {
interface = "enp4s0f0";
address = "10.33.64.1";
};
};
system.stateVersion = "24.05";
}