You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
22 lines
450 B
22 lines
450 B
{ config, ... }:
|
|
|
|
{
|
|
services.nix-serve = {
|
|
enable = true;
|
|
secretKeyFile = config.sops.secrets."cache/key".path;
|
|
};
|
|
|
|
services.nginx = {
|
|
enable = true;
|
|
virtualHosts."cache.${config.networking.domain}" = {
|
|
locations."/".proxyPass = with config.services.nix-serve;
|
|
"http://${bindAddress}:${toString port}";
|
|
};
|
|
};
|
|
|
|
sops.secrets."cache/key" = {
|
|
sopsFile = ./secrets/cache.key;
|
|
format = "binary";
|
|
};
|
|
}
|
|
|