You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
26 lines
370 B
26 lines
370 B
{ lib, ... }:
|
|
|
|
with lib;
|
|
|
|
{
|
|
virtualisation.docker = {
|
|
enable = true;
|
|
|
|
daemon.settings = {
|
|
group = mkForce "users";
|
|
};
|
|
|
|
autoPrune = {
|
|
enable = true;
|
|
dates = "weekly";
|
|
};
|
|
};
|
|
|
|
hardware.nvidia-container-toolkit.enable = true;
|
|
|
|
systemd.sockets."docker" = {
|
|
socketConfig = {
|
|
SocketGroup = mkForce "users";
|
|
};
|
|
};
|
|
}
|