You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

32 lines
712 B

{ pkgs ? import <nixpkgs> {} }:
let
pkgs = import (builtins.fetchTarball {
name = "nixos-21.05";
url = "https://github.com/nixos/nixpkgs/archive/21b696caf392ad6fa513caf3327d0aa0430ffb72.tar.gz";
sha256 = "1056r3383aaf5zhf7rbvka76gqxb8b7rwqxnmar29vxhs9h56m5k";
}) {};
in pkgs.mkShell {
buildInputs = with pkgs; [
(hunspellWithDicts [
hunspellDicts.en-us
hunspellDicts.de-de
])
(texlive.combine {
inherit (texlive) scheme-full;
})
python38Packages.pygments
(pkgs.vscode-with-extensions.override {
vscode = pkgs.vscodium;
vscodeExtensions = with pkgs.vscode-extensions; [
james-yu.latex-workshop
];
})
qtikz
];
}